[Rdo-list] Fwd: Re: Fwd: Re: Canonical OpenStack Messaging

Rich Bowen rbowen at redhat.com
Tue Feb 25 15:10:12 UTC 2014

I received the following feedback from a user. Not sure if Daniel is on 
this list to answer followup questions, but I'll encourage him to join.


-------- Original Message --------

Date: 	Tue, 25 Feb 2014 12:39:01 +0800
From: 	Daniel Veillard <veillard at redhat.com>




   BTW I installed RDO from scratch on a CentOS 6.5 box 2 weeks ago,

The Good:
   1/ the instruction worked, no tweaking, packstack did work
      even with the horrible connection I'm having at the moment
   2/ the setup instructions are clear and simple
      however it should be made clear that the host where the
      installation is done should have a fully qualified DNS name
      as that's one of the small issue I hit, and people doing testing
      are likely to do it on machines without that set up
   3/ I got the console working just fine

The Less Good:
   Creating a CentOS test instance should be no more than an
   additional 2 steps, it wasn't

      Step 1 if CONTROL_NODE is not the IP (previous document referenced
      an iP) then one need to pass a FQDN, in my case
         http://test/dashboard  fails with
	   "Openstack dashboard Something went wrong an unexpected error
	    has occured ..."
	http://test.veillard.com/dashboard works
	http:// works
      So either make sure the FQDN is part of the requirement in step 0
      or like for the quickstart use $YOURIP that will also be coherent

      => I wonder how many get stuck at that step thinking their
         installation is broken

      Step 2 and 3 just fine

      Step 4:
        that's another issue, the default is a Fedora image, and that
        worked fine but for CentOS i had to
          - click the image resource link
	 - then follow CentOS 6.5 images
        one end up at
        a CentOs image, one month old, hosted on Fedora, with no checksum
        no README, etc ...
        I do think that
        need to be updated to point to a real web page, on the CentOS project
        with a current image and followup instruction dedicated to people
        who were following the RDO instructions

       In comparison the http://cloud-images.ubuntu.com/ link for
       "Ubuntu cloud images" at least has some pointers, we can do way
       better and streamline for an RDO setup

    Step 5:
      Launch the instance instruction failed for me, just providing a
      name was not sufficient, the error was
        "At least one network must be specified."
      it got me to the Networking tab and i had to pick the private
      network from the available networks only selection, then launch

    Step 6:
      it looks like it worked and got a IP, but the instance
      still says "IP address" , and trying in step 7 to ssh
      to failed, both from the remote workstation and
      when logged as root

      Then messed up creating a local pool of IPs as suggested at
     but tuned to the local IP address, registering the network was fine
     but it never seems used when trying to associate a floating IP to
     the instance.

   => IMHO we need to fix quite a few things so that instructions work
      out of the box up to running and ssh'ing to a CentOS instance.

   Rich, are you able to sort and fix those points at least up to
   networking setup ?
   KB, do we have a page with QCow2 ready CentOS image on the centos site
that we could link to, and provide RDO tuned instructions ?


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.rdoproject.org/pipermail/dev/attachments/20140225/bf232597/attachment.html>

More information about the dev mailing list